Downloading Older Versions of xScope

I'm still using Snow Leopard, Leopard, or I wish to re-download my version of xScope 2.5.1.

We are no longer actively developing or supporting versions 2.2.3, 2.5, and 3.2.2 of xScope. However, if you wish to download either of these versions, you can do so from the links provided below.

If you're still running Snow Leopard, you can download xScope 3.2.2 from this link:
http://iconfactory.com/assets/software/xscope/xScope-3.2.2.zip

If you're still running Leopard, you can download xScope 2.2.3 from this link: http://iconfactory.com/assets/software/xscope/xScope_223.zip

If you want to download version 2.5.1 of xScope (only runs on OS X 10.6 and above), you can do so from this link: http://iconfactory.com/assets/software/xscope/xScope_251.zip