xScope Problem

Denis Hennessy's Avatar

Denis Hennessy

19 Jan, 2012 08:08 PM

I have my mac (wired) and iPad both running xScope but nothing happens. Do I have to do something?

Denis

  1. Support Staff 1 Posted by Gedeon on 19 Jan, 2012 08:13 PM

    Gedeon's Avatar

    First, check to make sure both your iOS device and your Mac are on the same network. For example, if your Mac is using Wi-Fi and your iPhone is on 3G, you won't see the Mac listed on the iPhone. You'll have the fewest problems if the Mac and iOS device both connect to the same Wi-Fi network.

    If that doesn't fix the issue, the preference to allow Mirror connections might be turned off. Check that devices on the local network can view your desktop in the Mirror pane of xScope's preferences.

    If you're still having issues, try turning off Bluetooth on your iOS device, as it can interfere with the Wi-Fi network. After that, restart your device to reset the network configuration.

    And if all else fails, check to see if your Mac has its firewall enabled. If so, make sure that you're allowing xScope to accept incoming connections. If you're not, the Mirror app won't be able to connect.

  2. Gedeon closed this discussion on 19 Jan, 2012 08:13 PM.

  3. Denis Hennessy re-opened this discussion on 19 Jan, 2012 08:28 PM

  4. 2 Posted by Denis Hennessy on 19 Jan, 2012 08:28 PM

    Denis Hennessy's Avatar

    I don't have OSX firewall turned on. I tried also installing the iOS app on an iPhone. Once I disabled bluetooth and restarted it (!!!!) it works on the iPhone but still not on my iPad2 (I've also restarted that).

    Update: while typing this, it's now stopped working on my iPhone as well.

  5. Support Staff 3 Posted by Gedeon on 19 Jan, 2012 08:45 PM

    Gedeon's Avatar

    Denis,

    Just do me a favor and turn off blu tooth on your Mac and see if that makes a difference at all. No idea why it would just stop working.

  6. Gedeon closed this discussion on 19 Jan, 2012 08:45 PM.

  7. Gedeon re-opened this discussion on 19 Jan, 2012 08:45 PM

  8. 4 Posted by Denis Hennessy on 19 Jan, 2012 08:58 PM

    Denis Hennessy's Avatar

    Nope, that didn't help (I then had to re-enable it to use keyboard&trackpad). To recap, here's the situation now:

    Mac (iMac, running 10.7.2, no firewall), now disconnected from wired ethernet and using same wifi access point as mobile devices
    iPhone 4S (5.0.1) bluetooth disabled. Worked briefly earlier but no longer.
    iPad 2 (5.0.1) bluetooth disabled. Has not worked at all.

    All devices accessing the Internet normally through their wifi connection.

  9. Support Staff 5 Posted by Gedeon on 23 Jan, 2012 05:29 PM

    Gedeon's Avatar

    Denis,

    If you're still having trouble, you may need to reset the Bonjour service on your computer. To do so, first quit out of both xScope on your Mac and the Mirror app on your iOS device. Then open the "Terminal" app, which can be found in the Utilities folder in your Applications. Once it's loaded, type in the command "sudo killall mDNSResponder" (without quotes) and hit enter. Terminal will ask you for a password, which is the user password for your computer. When typing in the password, no text will show up in the window. This is normal. Just type it like you normally would and hit enter. Bonjour should then be restarted, and you can open up xScope and then the Mirror tool to connect.

    Please let me know if this works for you or not. Thanks!

  10. 6 Posted by Denis Hennessy on 23 Jan, 2012 05:46 PM

    Denis Hennessy's Avatar

    Hi Gedeon,

    Thanks for getting back to me. I followed your instructions but it didn't help. However, it got me thinking about whether it was something to do with my office wifi network. My home office has a D-Link DIR-615 wifi router and normally everything connects to that in my office. However, I also have an Apple Airport Extreme in my living room and I tried connecting my iMac, iPad and iPhone to that instead. I restarted the iOS apps and they both instantly started working. I tried changing everything back to the D-Link router and again they all failed. So, problem solved for me but I bet other people have the same problem. If there's anything I can do to help let me know.

    Cheers,
    Denis

  11. Support Staff 7 Posted by Gedeon on 23 Jan, 2012 07:55 PM

    Gedeon's Avatar

    Denis,

    The router stuff explains a great deal, it must be the source of the problem. Your router is blocking Bonjour access somehow. You can test this by downloading a small app called Bonjour Browser. If, when you run this you don't see any devices running when using the D-Link, you'll know for sure. More info here:

    http://support.iconfactory.com/kb/xscope/trouble-connecting-to-the-...

    If you can take a look and confirm for me, that would really help. And BTW, THANK YOU for your help in getting this pinned down. There are indeed other users who are having the same problems and we need to know what to tell them. So this all is a great help.

  12. 8 Posted by Denis Hennessy on 23 Jan, 2012 09:16 PM

    Denis Hennessy's Avatar

    OK, it gets more interesting..

    When all three machines (iMac, iPad, iPhone) are on my D-Link wifi router, they all report 3 items in the bonjour browser:

    _apple-movdev._tcp.
    _IF-CKServer._tcp.
    _ubd._tcp

    For some reason, as I was looking at it, both the iPad and iPhone Mirror apps started working. I've tried rebooting and it now works every time. It's like a reverse-hiesenberg effect, looking closely at it makes it work.

    So, at this point things are working on both wifi networks. If it fails again, I'll try the bonjour probe again.

    Thanks,
    Denis

  13. Support Staff 9 Posted by Gedeon on 23 Jan, 2012 09:24 PM

    Gedeon's Avatar

    Great, at least its working for you now. Thanks Denis!

  14. Gedeon closed this discussion on 23 Jan, 2012 09:24 PM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac